It’s all in the details: T-Splines modeling and photorealistic rendering in Fusion 360

Alex Lobos - Rochester Institute of Technology
Colin Smith - Autodesk

Learning Objectives

- Learn best practices and techniques for T-Splines modeling in Fusion 360.
- Generate and explore complex organic shapes with good surface quality.
- Use Fusion 360’s rendering environment to quickly obtain photorealistic results.
- Integrate workflows that maximize form development and visualization of design concepts.

Class description

Fusion 360 offers powerful tools for creating models and renderings with great attention to detail. This class focuses on two key elements that are critical in product design: first one is T-Splines modeling, which allows the creation of complex forms in a quick way while maintaining high-quality surfaces. People often comment that using T-Splines for organic shapes cuts down modeling time from hours to minutes. This method also lets designers and engineers to easily explore forms without distractions from complicated workflows. The second key element of this class focuses on rendering, a critical tool for visualizing design intent and “selling” designs to broader audiences. Fusion 360 offers a powerful and simple platform for photo-realistic rendering, eliminating the use of a separate software package.

Your AU Experts

Alex is an industrial designer and educator, focusing in sustainable design, emotional attachment, and CAD applications. He is an Expert Elite for Fusion 360, AU Featured Speaker, member of Autodesk University’s Advisory Council, and recipient of Fusion 360’s Education Award. He has collaborated with Autodesk since 2011 on research projects and teaching methods for design, engineering and sustainability. Alex is an Associate Professor and Director of the Industrial Design graduate program at Rochester Institute of Technology, in upstate New York. His research has been sponsored by companies such as Autodesk, AT&T, Colgate-Palmolive, General Electric, Kraft, Staples and Unilever. More information on Alex’s research, students’ and professional work can be found at: http://cias.rit.edu/faculty-staff/154

Colin Smith is a product manager on the Fusion 360 team. He has been at Autodesk since 2006. Prior to joining Autodesk, Colin was a product manager at Alias Systems where he was responsible for Alias Studio Tools and SketchBook Pro. Colin is based in Toronto, Canada.
T-splines benefits for CAD

T-Splines modeling is an innovative method that allows the creation of complex shapes while maintaining a simple geometry. Typical NURBS-based models tend to add faces and points throughout the entire model as the shape of the model grows in complexity. T-Splines, in contrast, allow for surface complexity to be added only where necessary, resulting in significantly less faces. This helps in maintaining a clean surface quality and adding details with more precision and ease. T-Splines are based on T-points that divide vertices and edges only at individual points by using partial isoparms (Figure 1). These partial isoparms subdivide surfaces in specific regions, instead of throughout an entire body.

![Figure 1: Partial isoparms allow for complex shapes while maintaining a simple geometry.](image)

Fusion 360’s t-spline modeling in design process

Autodesk’s Fusion 360 is a hybrid CAD software that combines T-Splines and parametric modeling in a single environment. This combination provides more flexibility for form exploration and development of complex shapes (via T-Splines) while also integrating parametric precision that is needed for manufacturing and fabrication of objects.

This class focuses on modeling in the T-Splines environment, which in Fusion 360 is called “Sculpt”. This environment offers two key benefits to CAD designers and engineers: modeling organic shapes out of primitive objects; and manipulating complex surfaces in real time. These two features are the backbone of a more fluid and experimental type of computer modeling, and set Fusion 360 apart from other CAD programs.

Modeling organic shapes out of primitive objects

Based on the T-Spline geometry creation, Fusion 360 can add partial isoparms to specific parts of a body, leading to very complex shapes that would be practically unimaginable with a traditional parametric workflow (Figure 2). This process is a lot more intuitive in terms of expanding a simple shape into a more complex body, with Fusion 360 adjusting deviation of surfaces automatically, maintaining surface tangency and continuity.
Figure 2: A primitive body morphed into a complex shape by pulling faces.

Manipulating complex surfaces in real time
Parametric modeling relies on sketches that are transformed into three-dimensional shapes driven by a linear axis or a geometric path. With T-Splines, shapes can be generated freely without referencing a specific axis or sketch (Figure 3). This means that designers and engineers don’t have to stop their form exploration to figure out “what or how to do next”, but rather react to the model in a more direct way and seeing changes in the geometry immediately as points in the surface are moved, scaled or rotated.

Figure 3: Edit Form allows to select sections of the body and move, scale and rotate them. It also allows for new geometry to be generated out of the selected sections.

Photorealistic renderings for effective communication of design intent
Effective communication of new ideas to key stakeholders is a key aspect in any creative process. In the case of CAD, renderings serve as vehicle for communicating final design intent to members of a product development team. They also serve as marketing tools to illustrate to broader audiences the virtues and benefits of a new design in a compelling and engaging way.
Fusion 360 includes a powerful rendering environment that provides quick and effective results. While running a quick rendering provides a great visualization of a design, paying attention to specific aspects will transform the renderings from just being illustrative to being captivating and moving. Four rendering strategies for achieving superior results are:

**Finding the right appearance**
Fusion 360’s rendering environment offers an extensive library of materials, ranging from wood to metal, paint, fabric, and many other categories. A great first step for creating a rendering is to spend time playing with applying different materials to parts of the model (Figure 4). This helps to understand better how the model’s shapes react to light, angles, and other aspects of a three-dimensional environment. In addition to materials, playing with color, reflectivity, and other settings of materials also helps in identifying the settings that best communicate the virtues that were envisioned during the creation of a model. During this exploration stage it is important to keep in mind fabrication limitations of materials, in order to avoid proposing a part that couldn’t be fabricated out of a specific material.

![Figure 4: A body displayed with copper, glass and wood applied to it.](image)

**Effective storytelling**
A good rendering doesn’t happen by accident. While Fusion 360 will generate renderings from popular angles and viewers can quickly get a general sense of a specific design this way, good renderings are about purposeful storytelling. When setting up each rendering there needs to be a clear goal of what wants to be communicated. Renderings can focus on things such as appearance and materials, proportions of the product, parting lines, parts fitting together, differences between textures, transparency, perceived weight of the design, interaction with the user, etc (Figure 5). When the purpose of each rendering has been established, it will be a lot easier to setup a scene that best communicates specific aspects of the design intent.
Importance of camera angles

The view from which a product is seen can make it or break it. It can highlight its proportions, move the eye to specific parts of the design, or use strong depth of field to communicate a more abstract composition and generate more emotional reactions from the viewer (Figure 6). A good rendering comes from moving the model around until the best angles are discovered. At this point it is also important to pay attention to the background or additional elements in the scene in order to achieve a balanced visual composition.

Figure 6: A dramatic camera angle and depth of field help the eye go to a focal point and then move around the design to appreciate more details.
The power of lighting

Lighting is a fundamental part of a good rendering. It is not just about having enough light in the scene but rather about finding an angle, color, type and intensity that complements the design and whatever details want to be highlighted. As a rule of thumb, if the angle moves, the lighting needs to be adjusted. Also, if the angle stays the same but the goal of the rendering changes (i.e. highlighting material reflectivity versus shape and profile) then the lighting needs to be adjusted as well. Lighting helps to communicate complex elements such as surface continuity, material smoothness, etc., but it can also add dramatism to a scene, elevating the perceived value of a design (Figure 7).

Figure 7: By changing the lighting angle it is now easier to understand the profile of the shape and to highlight aspects such as the round profile of the left part of the object.
Step-by-step example: Backpack
In order to illustrate the concepts described above, a step-by-step example of a backpack is used. The backpack was chosen because of its organic and complex shapes, as typical in soft-good product categories. This example also works well for creating interesting renderings, given the bold combination of colors, materials and finishes that athletic soft-goods have.
# Create basic shape for backpack

## Step 1: Insert Sketch Canvas

Open Fusion 360. Go to Insert > Attached Canvas.

Set an attached canvas for a reference image of a backpack, using the settings to the right.

Go to: Browser > Canvases. Look for the image name, “right-click” and select Calibrate.

Click the left and right ends of the shoe in the sketch. Set width to **340 mm**.

## Step 2: Create the basic box

Go to: Create > Create form. This changes the workspace to Sculpt.

Go to: Create > Quadball and use settings shown to the right, making sure that you set symmetry from left to right.

Use Modify> Edit Form to turn the ball into a box.

Set selection filter to “Faces” and pull them accordingly.

Hold ALT key when pulling faces will create new faces.

The resulting box should have 6 faces width-wise, 7 faces length-wise and 2 faces depth-wise.
Go to Modify > Edit Form. Jump between Selection Filter > Faces and Vertex to adjust the shape of the box as shown to the right.

**Step 3: Create the box's open sides**

Delete the faces as shown to the right, in order to open up the top of the bag. In order to delete faces, simply select them and press the Delete key.

Go to Modify > Bridge. In the upper right corner of the box, select the vertical edge facing front.

Without exiting Bridge, select the horizontal edge in the front edge that is closer to the half of the box (where the symmetry line is).

Set the number of faces to “2,” and press OK.
### Step 4: Create additional openings

Repeat the workflow described in Step 3 in order to open the bottom and side sections of the box.

Use **Modify>Edit Form and set selection to edges in order to refine the thickness and flow of the faces.**
## Create exoskeleton frame

### Step 5: Create a copy of the box

Go to Browser > Bodies and look for the body of the box. Right-click and select Copy.

Go to Browser, and right-click the Bodies folder. Select Paste.

Rename the bodies so that you can differentiate them easily.

Go to Browser > Bodies and look for the body of the box. Press on its “lightbulb” icon to hide it.

### Step 6: Add thickness to the box

Go to Modify > Thicken. Select the body and set it to project outwards, with the settings to the right.
**Step 7: Create the back straps**

Go to Sketch > Create Sketch. Select the right plane, and use Spline to draw the path of the strap as shown to the right.

Use the handles to refine the spline’s shape.

When finished, press “Stop Sketch”

Go to Create > Pipe. Select the spline and adjust the settings to get a closed body with the appropriate diameter, number of faces and sections, as shown to the right.

Go to: Modify > Edit Form. Adjust the faces and vertices as needed to refine the strap’s shape.

Go to: Symmetry > Mirror – Duplicate. Select the strap and use right plane to mirror it.
### Step 8: Connect the straps to the main body

Go to: Symmetry > Clear Symmetry, and select the main body.

Go to Modify > Bridge. Select the face in the top end of the straps.

Without exiting Bridge, select the corresponding face in the main body.

Set the number of faces to "1," and press OK.

Repeat the workflow for the other strap.

### Step 9: Open up the frame in the back section

Go to Modify > Bridge. Select four faces in the third row of the body’s inner back panel.

Without exiting Bridge, select the corresponding four faces in the outer back panel.

Set the number of faces to "1," and press OK.
Use Modify>Edit Form and set selection to edges in order to refine the thickness and flow of the faces.

### Create interior bag

| **Step 10** Create bag body and fill side holes | Repeat Step 5: Create a copy of the box, to be used for the inner bag.  
Go to Symmetry > Mirror - Internal. Select two adjacent faces (left-right) at the center of the body to make them symmetrical.  
Go to Modify > Fill Hole. Select one of the edges of the side hole and set the filling mode to Reduced Star. |
|---|---|

<p>| <strong>Step 11</strong> Close lower hole | Go to Modify &gt; Bridge. Select the two upper edges of the lower hole and bridge them with the corresponding two lower edges. |</p>
<table>
<thead>
<tr>
<th>Step 12: Even surfaces and add thickness</th>
<th>Go to Modify &gt; Fill Hole. Select the two opposite vertex to close them together.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Go to Utilities &gt; Make Uniform. Select the body to smooth out the surfaces and remove potential surface overlaps.</td>
</tr>
<tr>
<td></td>
<td>Go to Modify &gt; Thicken. Select the body and set it to project outwards, with the settings to the right.</td>
</tr>
</tbody>
</table>

**Create upper flap**

<table>
<thead>
<tr>
<th>Step 13: Create box</th>
<th>Go to: Browser &gt; Bodies. Right-click on the exoskeleton body and click on Selectable/Unselectable</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Go to: Create &gt; Box. Create a box with 8 faces width-wise, 2 faces length-wise and 6 faces depth-wise.</td>
</tr>
<tr>
<td></td>
<td>Make sure that you add symmetry around the box’s width and length.</td>
</tr>
</tbody>
</table>
### Step 14: Shape the box into top flap

Go to: Modify > Edit Form. Set Selection Filter to **Body Control** and scale the box so that it has the basic proportions of the flap. Click Ok.

Delete some of the inner edges of the box to simplify the geometry, keeping the outer edges.

Go to: Modify > Edit Form. Use the different selection filters to move/scale/rotate faces, edges and vertex and obtain the curved shape of the flap.

### Step 15: Refine the flap

Select the bottom faces of the flap and delete them to turn the body into an open surface.

Select the top surfaces of the flaps’ right side.

Go to Modify > Subdivide. Adjust settings to subdivide into 1 Length face and 8 Width faces.
Go to: Modify > Edit Form. Set Selection Filter to Vertex.

Select every other vertex along the center edge of the flap and use the triad to scale/move them, creating a creased surface.

Go to Modify > Thicken. Select the body and set it to project outwards, with the settings shown to the right.

Create additional details

<table>
<thead>
<tr>
<th>Step 16: Create lower flap</th>
<th>Refer to Steps 13, 14 and 15 to create the lower flap.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 17: Create inner pocket (optional)</td>
<td>Use some of the tools covered above to create an inner pocket for the bottom section.</td>
</tr>
</tbody>
</table>
Step 18: Create inner pocket (optional)

Use some of the tools covered above to add tabs that would hold the flaps when extended to cover the backpack’s openings.

Create Renderings

Step 19: Set Appearance

Go to Setup > Appearance.

Browse the material library and identify materials for your model.

Select to apply materials to bodies/components or faces.

Drag a material’s icon to a component to assign it.

Go to Setup > Texture Map Controls. Select each of the bodies and test different projection types to identify the one that displays the material most appropriately.
| Step 20: Set Scene Settings | Go to Setup > Scene Settings.

Use the Brightness slider to adjust light’s intensity.

Click the Position icon to adjust lighting’s angle and scale.

Click the Color bar to adjust the background color.

Go to the Ground section to set how the model interacts with the environment.

Use Camera settings to adjust focal length and exposure.

Use Depth of Field to set a point of focus in the scene, away from which blur will increase incrementally. |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Scene Settings" /></td>
<td><img src="image2" alt="Scene Settings" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Step 21: Set views</th>
<th>Use the ViewCube in the upper-right corner of the workspace to rotate the model and find good camera angles.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="ViewCube" /></td>
<td><img src="image4" alt="ViewCube" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Go to Browser &gt; Named Views. Right-click and select New View to save your current view.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5" alt="Browser" /></td>
<td><img src="image6" alt="Browser" /></td>
</tr>
</tbody>
</table>
### Step 22: Create render

Click the Render panel to create final renderings. You can set dimensions, in-cloud or local rendering, and image quality.

The rendering job list will be populated in the Gallery strip at the bottom of the workspace.

Double-click any thumbnail to open the rendering, save, share, re-render and other options.