Annotation Scaling in AutoCAD®: Bringing the Technology Home

KaDe King – U.S. CAD

AC2660-L  Learn how to implement annotation scaling in your organization. Whether you would like to start with baby steps or go full bore, in this class you can learn all levels of migrating these tools into your daily workflow. Learn about annotation scaling and how it works with hatching, text, linetype scale, dimensions, and all of the other options. See how you can “bring this technology home,” improve your productivity, and reduce unnecessary hours spent on annotations. This class is designed to assist you in building a new workflow for annotation in your organization.

Learning Objectives
At the end of this class, you will be able to:

• Explain annotation scaling
• Integrate annotation scaling into your current workflow
• Use annotation commands, tools, and styles
• Reduce the time spent annotating drawings

About the Speaker
KaDe is a technical specialist for U.S. CAD, and provides training, network licensing services, and migration services. She has been using AutoCAD® for 26 years and has been a trainer for 20 years. KaDe is an AutoCAD Certified Professional and an Autodesk Certified Instructor. She has been the recipient of the Autodesk Instructor Quality Award twice, and has presented at AU 8 times. Her experience is widely varied and includes real-world application of AutoCAD in the AEC, mapping, civil, and manufacturing industries. She enjoys teaching, and her specialty is relating to the class participants and helping them to get the most out of the training course, whatever it may be.

KaDe.King@uscad.com
Annotation Scaling

Spend Less Time Annotating Drawings!

Getting annotation placed on our drawing sheets that is accurate and meets our organization’s CAD standards is one of the biggest challenges we face. Especially when it comes to the amount of time spent getting the annotation in place.

Annotative Scaling (in AutoCAD 2008 and above) can be used as a way to reduce time spent creating annotations on our drawings.

Annotative Scaling can be used for the following items:

- Linetypes
- Text
- Dimensions
- Multileaders
- Hatches
- Blocks
- Attributes

Doing the Linetype Dance

Does this sound familiar?

1. Set LTSCALE to 40 (or some other number) in model space so that you can see your linetypes while you’re doing your work.
2. Print your drawing from your layout. OOPS, your linetypes didn’t print correctly.
3. Set LTSCALE to 1.
4. Set PSLTSCALE to 1.
5. Reprint your drawings.

How much time is wasted resetting LTSCALES and reprinting?

Doing the Layer Dance

Does this sound like your office?

- Do you have multiple dimension styles for each scale factor that you use?
- Do you have a layer for every scale factor that you use?
- Do you have to create multiple versions of the same text, dimension, etc… for each scale factor that you use?
- Do you have to freeze layers for every viewport for all of the annotation layers that you’re NOT using for that viewport?

How much time is wasted creating and manipulating multiple objects, styles and layers?
Did you notice in Figure 1 that the text heights are different in each viewport?

This is because the text and dimensions were created at a specific scale. In order to create text that looked good for each viewport they would have had to create multiple dimensions and text at different sizes and then manipulate the layers individually in each viewport.

Another method that some organizations use is to create text and dimensions on top of the paper space. But that comes with its own challenges, particularly the challenge of the viewport changing and the text having to be repositioned. Even when using the DIMREGEN command, the dimension often has to be adjusted.
Did you notice in Figure 2 that the text heights are consistent across each viewport?

This is because the text and dimensions were created with annotative styles and assigned multiple scale factors. Using this technique ensures that the text and dimensions will create multiple representations automatically for each scale factor.

This method saves time for the person creating the drawing. All annotative objects are automatically scaled based on the scale factors assigned to them.
Using Annotation Commands, Tools, & Styles

The THREE things you need to know to make annotation scaling work for you!

1. You must have an annotative style set current to create annotative text, dimensions or multileaders. In Figure 3 below, note how the styles have a triangular shape in front of the name. This indicates that it is an annotative style.

![Figure 3 - Annotative Styles](image)

2. Before you start creating annotative objects, make sure the Annotation Scale is set to an appropriate scale, regardless of whether you are in regular model space or model space through your viewport. **TIP: If you are in your viewport, don’t type ZOOM 1/100XP to change the viewport scale. This will only set the view scale and not the annotation scale! Using the toolbar or the properties menu will ensure that the annotation scale is also set.**

![MODEL toolbar](image)

3. Know what ANNOAUTOSCALE does and how to control it. This variable controls what scale factors are automatically assigned to all of your objects! By default, if the button is enabled when you switch scale factors, ALL of your annotative objects will have the new scale factor added to their list of scale factors. That may sound good, but it won’t be what you want all the time. Only enable this setting if you really mean it!!

![Annotation Scale button](image)
Annotative Linetypes

Setting linetypes to be annotative is a simple transition! The variable to control your annotative linetype scaling is MSLTSCALE (0 or 1). Setting MSLTSCALE to 1 enables linetypes to read the current annotation scale that is set and use it as its scale factor.

1. Set MSLTSCALE to 1.
2. Set PSLTSCALE to 1.
3. Set your LTSCALE to 1 (or a slight variation).

Exercise 1 – Setting Annotative Linetype Scale

2. Select the Site layout tab. Notice that the linetypes looks appropriate in the layout.
3. Select the Model tab. Notice the linetypes are almost solid in model space.
4. Set the Annotation Scale to 1:10 (from the Annotation Scale fly-out in the bottom right corner of the screen).
5. Type MSLTSCALE and set it to 1.
6. Type RE (for Regen). See how the linetypes have updated?
7. Type LTS (for LTSCALE) and set it to .5.
8. Type RE (for Regen).

You can see how using MSLTSCALE will allow you to not have to change your linetype scale between model space and your layouts. You can also see how LTSCALE will help you make minor tweaks to your linetype scale.
Annotative Text

Having your text height size automatically is a huge time saver! Text can be added either through the main model space or in model space through the viewport.

1. You need to have a text style that is set to Annotative. Notice how the prompt changes to say “Paper Text Height” instead of just “Height”. That is because you are now specifying the paper or printing text height instead of a model space height.

2. Make sure Annotation Scale is set correctly.
3. Start your text command and when prompted for the height, enter the height that you want the text to be in your layout.
4. AutoCAD will automatically multiply the size of your text based on your current annotation scale.

Tips

- You can set text height in your text style (if that is your standard) or you can set it when you create your text.
- When using paragraph text, pick your first corner, then before you pick your second corner for your text box, type H for Height and set the “paper text height” at that point. It’s much easier than if you do it when you get into the MTEXT editing box and will save you some grief.
Exercise 2 – Annotative Text

1. Open the drawing Landscaping Plan – Text.dwg.

2. Make sure the Annotation Scale is set to 1:10 (from the Annotation Scale fly-out in the bottom right corner of the screen).

3. Set the current layer to Annotation.

4. Go to the Annotate tab->Text panel and select the Labels text style from the text style fly-out.

5. Start the Multiline text command by typing T (for MTEXT) or by selecting it from the Annotate tab->Text panel->Multiline Text tool.

6. Pick the first corner of the text box in the inside of the house outline.

7. Type H (for Height) and press enter. Type .25 for the text height and press enter.

8. Select the opposite corner of the text box.

9. Type HOUSE for the label and set the justification to Middle Center.

10. Start the MTEXT command again and create a label with the text SHED that is inside of the shed.

See how the text automatically sizes to the correct height based on the Annotation Scale? Entering the “printable height” automatically generates the model height of the text.
Annotative Dimensions

The best thing about annotative dimensioning is that you will generally only need ONE dimension style per type of dimensioning that you are doing. You may still need multiple styles for other reasons, but never for scaling purposes! Dimensions can be placed in the main model space or in model space through your viewport.

1. Make sure the current dimension style is set to Annotative. Go to the “Fit” tab in the Dimension Style editor and look in the “Scale for dimension features” section.

2. Make sure the Annotation Scale is set correctly.

3. Place your dimensions as needed. They will be sized automatically.
Exercise 3 – Annotative Dimensioning


2. Make sure the Annotation Scale is set to 1:10 (from the Annotation Scale fly-out in the bottom right corner of the screen).

3. Set the current layer to Dimensions.

4. Set the current dimension style to Civil from the Annotate tab->Dimensions panel and the dimension style fly-out.

5. Start the Linear Dimension tool from the Annotate tab->Dimensions panel.

6. Dimension the two sides of the shed as shown below. Repeating the Linear Dimension tool as needed.
Annotative Multileaders

Multileaders have their own styles; therefore you will need to make sure you have a multileader style set as annotative before you begin.

1. Set the current multileader style to Annotative. Go to the multileader style editor (mleaderstyle or MLS) and modify the style. Go to the “Leader Structure” tab and look for the “Scale” setting to change it to “Annotative”.

2. Make sure the Annotation Scale is set correctly.
3. Place your multileaders as needed. They will be sized automatically.
Exercise 4 – Annotative Multileaders

1. Open the drawing Landscaping Plan – Multileader.dwg.

2. Make sure the Annotation Scale is set to 1:10 (from the Annotation Scale fly-out in the bottom right corner of the screen).

3. Set the current layer to Annotation.

4. Set the current Multileader style to Civil from the Annotate tab->Leaders panel and the Multileader style fly-out.

5. Select Multileader from the Annotate tab->Leaders panel or type MLD (for Multileader).

6. Create the leader as shown below and type MINIMUM 3’ CLEARANCE FROM PROPERTY LINE, then click outside the text box to finish the leader.
Annotative Hatch Patterns

One of the best things about annotative hatch patterns is the reduction in file size. This is because you are not creating several hatch patterns just to get the look you need in your viewports! Creating annotative hatch patterns is an easy process.

1. Make sure the Annotation Scale is set correctly.
2. Start the Hatch command and turn on the ANNOTATIVE button.
3. Select your pattern, and any other settings that you desire.
4. Use typical methods to select boundary areas (pick points or select).
5. Hatches will size automatically based on the current Annotative Scale.

Tips

- If you need your hatch pattern scale changed slightly (generally due to personal preference), just tweak the scale factor of the hatch pattern slightly. I might use a scale of anywhere from .5 to 2 to get the size I like. The viewports will automatically size it from there based on the viewport scale.
- Use the “Select New Boundary Set” function to reduce the time that AutoCAD takes to detect a boundary. After you pick the button make a window around the area you are working in or select limited objects to work with. Now when you use the Pick Points option, it will only detect boundaries from objects that you selected.
Exercise 5 – Annotative Hatching

1. Open the drawing **Landscaping Plan – Hatch.dwg**.

2. Make sure the **Annotation Scale** is set to **1:10** (from the Annotation Scale fly-out in the bottom right corner of the screen).

3. Set the current layer to **Hatching**.

4. Start the **Hatch** command from the Home tab->Draw panel->Hatch tool as shown below or type **H** (for Hatch).

5. Set the hatch pattern style to **ANSI32** in the Pattern panel as shown below.

6. Set the hatch pattern scale to **.2** in the Properties panel as shown below.

7. Turn on **Annotative** in the Options panel as shown below.

8. Hatch the concrete pad in front of the shed.
Annotation Scaling in AutoCAD®: Bringing the Technology Home

Annotative Blocks

Why would you need annotative blocks? Any block that needs to be the same size when it prints regardless of the viewport scale should be annotative. Some examples would be callouts, note bubbles, etc… Setting the blocks as annotative will make it much easier as the block will be sized automatically from the viewport scale.

1. When creating a block that you want to be Annotative, click the check box for “Annotative” in the Behavior section of the Block Definition dialog box.

![Block Definition Dialog Box]

2. You can also edit the annotative behavior of an existing block using the BEDIT command (block editor). Type BEDIT and click on an existing block. In the block editor go to the PROPERTIES palette and look for the “Block” section, then look for the Annotative property and change it to YES.

![Block Editor]

3. Before inserting the annotative block, make sure your Annotative Scale is set correctly.
Exercise 6 – Using Annotative Blocks

1. Open the drawing Landscaping Plan – Blocks.dwg.

2. Make sure the Annotation Scale is set to 1:10 (from the Annotation Scale fly-out in the bottom right corner of the screen).

3. Set the current layer to Annotation.

4. Start the INSERT command by typing I or go to the Insert tab->Block panel->Insert tool.

5. Select the block with the name North Arrow – Imperial and place it on the left side of the drawing.

6. Start the INSERT command again and select the block with the name Bubble and place it next to the group of 4 shrubs in the front of the house. Type 1 for the attribute value.

7. Repeat the process to add 2 additional bubbles next to the other two trees with attribute values of 2 and 3.
Annotative Attributes

Setting attributes to be annotative can be useful when you want the text in a block to change size, but not the block itself.

To set an attribute to be annotative do the following:

1. In the Attribute Definition dialog box under the “Text Settings” section, select the “Annotative” check box.

2. Make sure the Annotative Scale is set correctly.
3. Insert the block and enter your attribute value(s). The text should scale appropriately.
Setting Additional Annotation Scales

Now that you have annotative objects you may want to add additional annotative scales to some of your objects. For example, if you are working in a viewport and created a hatch pattern, you may want to add another annotation scale to that hatch pattern so that it can be viewed in a viewport with a different scale factor.

There is more than one method to add additional scale factors to an object.

- Select the object, right-click and choose “Annotative Object Scale” from the right-click menu. Then click Add/Delete Scales. You will get a dialog box that will allow you to add additional scales for the object(s) that you selected. You can do other annotative scale tasks from this menu as well.

- From the “Annotate” tab in the “Annotation Scaling” panel, you can choose “Add/Delete Scales”. You can do other annotative scale tasks from this menu as well.
Exercise 7 – Adding Additional Scales

1. Open the drawing **Landscaping Plan – Adding Scales.dwg**.

2. Switch to the **Site** layout tab from the bottom right corner of the screen.

3. Notice that none of the text elements show up in the bottom view of the shed. This is because the viewport scale is set to 1:4 and all of our annotation elements are set to 1:10. To fix it we’ll need to add the 1:4 annotation scale to the needed elements.

4. Switch to the **Model** tab from the bottom right corner of the screen.

5. Select the **Multileader, the Text label, the two Dimensions & the Hatch pattern**.

6. Type the **OBJECTSCALE** command or go to the Annotate tab->Annotation Scaling panel->Add/Delete Scales tool (far right on the ribbon) as pictured below.

7. Click **Add** from the Annotation Object Scale dialog box.

8. Select the **1:4** scale from the **Add Scales to Object** dialog box and pick **OK**.

9. Select **1:4** from the **Object Scale List** and pick **OK**.
10. Select one of the annotative objects and notice that there is now a second version of the object that is a different size. Also if you hover over the object you will see two triangles now instead of one.

11. Hit **ESC** to deselect the objects.

12. Switch back to the **Site** layout tab.

13. Activate the lower viewport and **UNLOCK** it using the icon in the status bar as pictured below.

14. Notice how the text height is the same size as the viewport above? Also notice the scale of the hatch pattern.

15. Using only the grips edit the positions of the **Dimensions and the Multileader** to better fit in the viewport. Edit the size of the viewport as needed.

16. Lock the viewport when you are done.

---

**Exercise 8 – Creating Annotative Styles**

1. Open the drawing **Landscaping Plan – Annotation Styles.dwg**.

2. In the **Ribbon** switch to the **Annotate** tab.

3. Select the **Text Style** tool from the lower right corner of the Text panel or Type **ST** (for **STYLE**).
4. In the Text Style dialog box click **New** to create a new text style, name it whatever you want, and select any font that you would like.

5. Turn on the **Annotative check box** to make it annotative and pick **OK**.

6. Select the **Dimension Style** tool from the lower right corner of the Dimensions panel or Type **D** (for DIMSTYLE).

7. In the Dimension Style Manager pick **New** to create a new Dimension Style, choose the Standard style to build it from and give it any name and pick **CONTINUE**.

8. Switch to the **Fit** tab in the Dimension Style Editor and select the **Annotative check box** then pick **OK** and **CLOSE**.

9. Select the **Multileader Style** tool from the lower right corner of the Leaders panel or Type **MLS** (for MLEADERSTYLE).

10. In the Multileader Style Manager pick **New** to create a new Multileader Style, choose the Standard style to build it from and give it any name and pick **CONTINUE**.

11. Switch to the **Leader Structure** tab in the Multileader Style Editor and select the **Annotative check box** then pick **OK** and **CLOSE**.

12. Type **B** (for BLOCK) or select it from the Insert tab->Block Definition panel->Create Block tool. Notice the **Annotative** check box. Hit **ESC** to exit the Create Block dialog box. Switch to Model Space and select the **North Arrow**. Then right-click and select the **Block Editor** option, open the **PROPERTIES** palette (CTRL+1) and scroll down to the bottom of the list, notice that **Annotative** is set to **Yes**.
Reduce the Time Spent Annotating Drawings – Useful Workflows!

Changing Existing Drawings to Annotative Scaling

Following are several workflows for converting existing content to annotative scaling. Linetype scaling does not require a special workflow. So the previous workflow described will work effectively.

Workflow for converting existing text, dimensions or multileaders to annotative scaling:

1. Bring annotative text, dimension, and multileader styles into the current file (try using Design Center!).
2. Identify dimensions, text or multileader objects that need to be converted to annotative objects.
3. Set the annotative scale current that you would like to apply to your objects.
4. Use QSELECT or manually select the objects you want to change.
5. When the objects are selected, go to the PROPERTIES palette.
6. Change the STYLE assigned to the objects to the correct annotative style.
7. If the ANNOTATIVE setting (in Properties) is not set to YES then change it to YES.

The objects should now be assigned to the correct annotative scale and should stay the same size as they were. If you need to you can select your text objects and change the “Paper Text Height” to a more appropriate height. Add scales as needed using “Add/Delete Scales”.

• **Using QSELECT to filter objects is an excellent way to speed up this process!**

Workflow for converting existing hatch to annotative scaling:

1. Set the annotative scale current that you would like to apply to your hatches.
2. Select any Hatch patterns you would like to change.
3. Go to the PROPERTIES palette.
4. Change the ANNOTATIVE setting (in Properties) from NO to YES.
5. Change the SCALE (in Properties) of the hatch pattern to 1 (or something similar).

The hatch pattern will now be annotative and have an annotative scale assigned to it. Add additional annotative scales as needed.

Workflow for converting existing blocks (and attributes) to annotative scaling:

1. Open the block in BEDIT, go to PROPERTIES and change ANNOTATIVE to YES.
2. Save the changes to the block and update your external file (if using wblocks).
3. Open the drawing that you’d like to update the block in.
4. Set the correct annotative scale current.
5. Using the INSERT command, bring in the new version of the block.
6. The Insert command will ask you if you want to redefine the block. Choose yes.
7. If you have any attributes, synchronize the blocks with the ATTSYNC command.
Exercise 9 – Changing an Existing Drawing to Annotative Styling

1. Open the drawing Existing Floor Plan.dwg.

2. In the Ribbon switch to the Annotate tab.

3. Set the Annotation Scale to 1/2”=1'-0” (from the Annotation Scale fly-out in the bottom right corner of the screen).

4. Set the following styles current
   - Text Style = Labels
   - Dimension Style = ARCH
   - Multileader Style = Leaders

5. Type QSELECT or right-click and select Quick Select from the menu.

6. In the Quick Select dialog box change the Object Type to Text and the Operator to Select All, and then pick OK. All of the text should be selected.

7. Open the Properties Palette (CTRL+1). Change the Style to Labels, and check to make sure Annotative is set to Yes. At this time you could also add additional annotation scales to the text as needed. Hit ESC to clear the selection when you are done.

8. Select the three dimensions that are in the drawing.

9. Open the Properties Palette (CTRL+1). Change the Dim Style to ARCH$0, and check to make sure Annotative is set to Yes. At this time you could also add additional annotation scales to the dimensions as needed. Hit ESC to clear the selection when you are done.

The key to this workflow is to make sure you have the following:

- Existing annotative styles
- Have the annotative scale already set BEFORE you change the objects to the new style
Integrating Annotative Scaling into your Current Workflow

Once the decision has been made to use Annotative Scaling, the most important thing you can do is to MAKE A PLAN! A poorly planned integration will lead to frustration for the CAD users and for management.

What decisions need to be made in regards to integrating Annotative Scaling?

- What annotative functionality do we need/want?
  - Linetype Scaling
  - Text
  - Dimensions
  - Multileaders
  - Hatches
  - Blocks
  - Attributes
- Who is going to update the organization’s template(s) and CAD standards with the necessary styles, blocks, attributes, variables, etc…?
- What functionality should be integrated first? Or should we roll out all the functionality at once?
- How and when should our CAD users be trained on the new standards?

What if we only want to “dip our toes” into the Annotative “Pool”?

*Starting Small*

If starting small works best for your organization, then start by integrating Linetype Scaling into your workflow. This is a relatively minor change and only requires two changes in your workflow.

1. Have the users change the following variable settings (these changes can also be applied with a script or by some other programming method)
   a. MSLTSCALE=1
   b. PSLTSCALE=1
   c. LTSCALE=1 (you should experiment with this setting in your drawings to get the best result)
2. Have the users set the Annotation Scale in model space.

Now the linetypes should show correctly whether you are in model space or paper space.
We want to use Annotative Scaling, but we only have the resources to “wade” in.

*Middle Ground*

If you have limited resources and need a quick start, then add to the “Starting Small” workflow by also integrating some or all of the following components:

- Annotative Hatches
- Annotative Text
- Annotative Dimensions
- Annotative Multileaders

Someone will need to update your styles in your template file(s).

The workflow for the users to add annotative text, dimensions, and multileaders is as follows:

1. The user sets the appropriate Annotation Scale in either the viewport or model space.
2. The user selects the appropriate style (text, dimension, or multileader) from the ribbon.
3. The user places the objects in model space as previously described in this document.
4. All text, dimensions, and multileaders will automatically scale based on the current annotative scale.
5. Additional scales can be added when needed by using the “Add/Delete Scales” command (OBJECTSCALE).

The workflow for the users to add annotative hatching is as follows:

1. The user sets the appropriate Annotation Scale in either the viewport or model space.
2. The user starts the Hatch command and enables the “Annotative” setting in the Hatch ribbon “Properties” panel or in the Hatch dialog box.
3. The user places hatch patterns as desired.
4. All hatch patterns will reflect the current annotative scale.
5. Additional scales can be added when needed by using the “Add/Delete Scales” command (OBJECTSCALE).
We want to use all of the Annotative features! We are ready to “dive” in!

*Full Bore*

For those who have the necessary resources to manage all the components, you can build on the two previous workflows by adding the following:

- Annotative Blocks
- Annotative Attributes

These are the most time consuming of all the annotative components. This is because you will need to assign someone to update your blocks. The number of blocks that you have that need to be set as annotative will determine the amount of time needed for this task. You may also want to consider new annotative blocks at this time.

This isn’t a time consuming process for the users, the bulk of the work is on the CAD Manager or those assisting with updating the blocks.

In addition to previous workflows, the users will also have to add the following:

1. Before inserting any annotative blocks, the user will need to set the appropriate Annotative Scale.
2. The user will place the blocks in model space and the blocks (or attributes) should scale automatically based on the current Annotative Scale.

Now that we have outlined three distinctive plans, you can decide where your organization fits in! Pick a plan that will work for you based on your available resources.

Also, consider that your local Autodesk reseller has technical specialists that can assist you with this process. You may have monetary resources, but perhaps not the time or experience to implement these changes yourself.

Training Your Users

You will need to provide your users with an overview of annotative scaling and the changes it will bring to your organization, along with some basic training on annotation scaling functionality.

- Meet in a conference room or via a conference call to discuss the changes to your standards and demonstrate the new workflow(s).
- Provide online or live training for your users to have them try out the new workflows hands-on (your favorite Autodesk Training Center can assist you with this).
- Provide additional workflow documentation that will be readily accessible for the user (Electronic or printed documentation).
Annotative Command and Variable Definitions – a list to rely on!

**ANNOALLVISIBLE**: Hides or displays annotative objects that do not support the current annotation scale. When this variable is set to 1, annotative objects that are assigned to more than one annotation scale will only display one annotation scale. This variable setting is saved individually for model space and each layout.

0 = Only annotative objects that support the current annotative scale are displayed
1 = All annotative objects are displayed

![Annotation Scaling Icon](image)

**ANNOAUTOSCALE**: Updates annotative objects to add the annotation scale when the annotation scale is changed. When using the icon below the functionality is set to the value of 4 (when enabled) or -4 (when disabled) by default. A negative value maintains the setting but disables the functionality.

0 (or any negative value) = Newly set annotation scale is not added to annotative objects
1 = Adds the newly set annotation scale to annotative objects that support the current scale except for those on layers that are turned off, frozen, locked or that are frozen only in the viewport
2 = Adds the newly set annotation scale to annotative objects that support the current scale except for those on layers that are turned off, frozen, or that are frozen only in the viewport
3 = Adds the newly set annotation scale to annotative objects that support the current scale except for those on layers that are locked
4 = Adds the newly set annotation scale to all annotative objects that support the current scale

![Annotation Scaling Icon](image)
**ANNORESET**: Resets the location of all alternative scale representations of any objects that are selected. You can use grips to edit positions of annotative objects, and then use this command if you need to synchronize the positions later. They will synchronize to match the location of the object’s current scale representation. In addition to typing this command it can also be selected by selecting the object and then accessing it from the right-click menu and then additionally from the Annotate Ribbon tab under the Annotation Scaling panel as shown below.

![Annotation Scaling Panel](image)

**ANNOUPDATE**: Updates existing annotative objects to match the current properties of their styles. When a text object is selected and the style assigned to it has a fixed paper space height, the size of the text will be changed. If an annotative object is updated to a non-annotative style, the object becomes non-annotative and any alternate scale representations are removed.

**CANNOSCALE**: Sets the name of the current annotation scale for the current space. You can only enter a named scale that exists in the drawing’s named scale list.

**OBJECTSCALE**: An annotative object can support several annotation scales for viewing at different scales. You can add or delete scales from the list of scales assigned to the selected annotative objects. Using this command will open a dialog box to edit the scales. In addition to typing this command it can also be selected by selecting the object and then accessing it from the right-click menu and then additionally from the Annotate Ribbon tab under the Annotation Scaling panel as shown below. You can also type this command as –OBJECTSCALE to use it from the command line only (perhaps in a script).

![Annotation Scaling Panel](image)

**SCALELISTEDIT**: Displays a dialog box with a list of predefined scales used throughout the program. This list can be easily modified to display only the scales you need. In addition to typing this command it can also be accessed from the Annotate Ribbon tab under the Annotation
Scaling panel as shown below. You can also type this command as -SCALELISTEDIT to use it from the command line only (perhaps in a script).

**SELECTIONANNODISPLAY**: Controls whether alternate scale representations are temporarily displayed in a dimmed state when an annotative object is selected.