Creature Modeling and Sculpting with Autodesk® Maya® and Autodesk® Mudbox®

Craig Barr – Autodesk, Media & Entertainment

DG4220 In this class, we will examine a creature modeling and detailing workflow using Autodesk Maya and Autodesk Mudbox software. We will begin with exploring creature concept techniques in Autodesk® SketchBook® Pro software and then review clean and optimized polygonal modeling tips and tricks in Maya. Next, we will send our base mesh into Mudbox and take an in-depth look at the processes of sculpting, detailing, and painting to bring our creature look and style to life.

Learning Objectives
At the end of this class, you will be able to:

- Describe the creature pipeline from concept to final model
- Use techniques for creating optimized polygonal models for a sculpting workflow
- Understand the sculpting and painting workflow within Mudbox
- Use tips and tricks for bringing render-ready models from Mudbox to Maya

About the Speaker
Craig Barr is a Technical Marketing Specialist at Autodesk specializing in Mudbox and Maya. Craig has over 14 years of experience in feature film, commercial and games production. He also runs the Mudbox blog on The Area http://the-area.com/blogs/craig

All things Mudbox on Twitter: @The_Mudroom

Craig.Barr@autodesk.com
**Thinking through the Concept: SketchBook Pro:**

To me, nothing beats the ability to simply scratch down an idea in the form of a thumbnail sketch or quick and simple drawing with pencil and paper. However, SketchBook Pro offers that same feeling with all the power that the digital world offers. Layers and Undo aside, the brush palette features some really nice, real-world tools that mimic traditional drawing/sketching tools and materials. Use the layers to store multiple iterations, ideas, and concepts. Another nice workflow is the ability to export and import PSD files, allowing you to work with Adobe Photoshop if you choose. For the concept creation process, creating thumbnail swatch sheets, detailed sketches and colour/texture ideas is fluid with SketchBook Pro.

**TIP:** SketchBook Designer vector curves can be exported as .DWG and imported into Maya.

---

**Polygonal Modeling: Creating a Base Mesh in Maya**

**Mission Statement/End Goal:** To create geometry that is clean (free of artifacts), has nice (edge) flow, subdivides efficiently, deforms properly and textures beautifully.

This class discusses the use of Maya for polygonal modeling, but all of the principles, guidelines and practices can be applied in any polygonal modeling package.
Clean Poly Modeling Guidelines:

Focus on keeping your mesh quadrangles. Mixed geometry types (ngons, triangles, quads, etc.) are supported by Mudbox, but lead to inefficient and problematic subdivision. **Keep your geometry clean.** What exactly does that mean? When working with polygons it is good practice to keep your mesh **uniform** and **balanced.** Uniform in the size and spacing of polygons and balanced with the flow of edges across the surface. These are the two fundamental basic principles to adhere to when working with quads. Following these principles allows for: **smooth and efficient subdivision** for sculpting, more accurate representation of **anatomy**, logical areas to **split UV seams**, better **texturing** results (less stretching), and, enhanced and more natural **deformation performance** in animation.

Other factors to consider when working with polygons to insure a clean mesh include: making sure all vertices are merged/welded and checking the face normals (often). A good way to do this, on the fly while modeling, is to use **Smooth Mesh Preview.** This provides a quick glimpse of how your model is going to look when subdivided. It’s also an excellent way to spot problem areas: inverted normals, holes (unwelded verts), double edges, to name a few. Use the following hotkeys to access Smooth Mesh Preview:

- “1” – base mesh
- “2” – cage over smooth mesh
- “3” – smooth mesh only

Of course, you can also model with all of the same tools in this state as well.

Another excellent way to spot some of these problem areas is turn on **Border Edges** (Display>Polygons>Border Edges). The thick lines should highlight the outer edges of your mesh and any defined texture borders. Thick lines in areas where they should not be are indicative of faces sitting on edges, flipped normal faces and holes (unwelded or non-merged vertices).

When working with Mudbox in your pipeline, take advantage of the one-click workflow. Using the **Send to Mudbox** command (under the File Menu) to test how your mesh will subdivide for sculpting is always a good idea. Mudbox provides a few warnings to help you identify these problems as well, but more on that in a little bit.

**Top Poly Modeling Tools in Maya** (mine anyways!):

Maya’s modeling tools are seemingly endless, so I have identified some of the more important tools for working with polygons and to help keep your mesh clean. See the chart on the next page.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Access</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Utility</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Freeze Transformations</td>
<td><img src="image" alt="icon" /></td>
<td>Modify&gt;</td>
</tr>
<tr>
<td>Delete History</td>
<td><img src="image" alt="icon" /></td>
<td>Edit&gt;Delete by Type&gt;</td>
</tr>
<tr>
<td>Center Pivot</td>
<td><img src="image" alt="icon" /></td>
<td>Modify&gt;</td>
</tr>
<tr>
<td><strong>Editing</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert Edge Loop</td>
<td><img src="image" alt="icon" /></td>
<td>SHIFT+RMB</td>
</tr>
<tr>
<td>Slide Edge Loop</td>
<td><img src="image" alt="icon" /></td>
<td>SHIFT+RMB</td>
</tr>
<tr>
<td>Spin Edges Fwds/Bwds</td>
<td><img src="image" alt="icon" /></td>
<td>CTRL+ALT+Right/Left</td>
</tr>
<tr>
<td>Merge Vertices/Edges</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Display Face Normals</td>
<td><img src="image" alt="icon" /></td>
<td>Display&gt;Polygons&gt;</td>
</tr>
<tr>
<td>Normals Size (adjustment)</td>
<td><img src="image" alt="icon" /></td>
<td>Display&gt;Polygons&gt;</td>
</tr>
<tr>
<td>Unlock Normals</td>
<td><img src="image" alt="icon" /></td>
<td>Normals&gt;</td>
</tr>
<tr>
<td>Reverse Normals</td>
<td><img src="image" alt="icon" /></td>
<td>Normals&gt;</td>
</tr>
<tr>
<td>Average Normals</td>
<td><img src="image" alt="icon" /></td>
<td>Normals&gt;</td>
</tr>
<tr>
<td>Soft Select</td>
<td><img src="image" alt="icon" /></td>
<td>“B” hotkey</td>
</tr>
<tr>
<td>Multi-Mode (selection)</td>
<td><img src="image" alt="icon" /></td>
<td>CTRL+RMB</td>
</tr>
<tr>
<td>To Shell</td>
<td><img src="image" alt="icon" /></td>
<td>CTRL+RMB</td>
</tr>
<tr>
<td>Move Pivot</td>
<td><img src="image" alt="icon" /></td>
<td>“Insert” hotkey</td>
</tr>
<tr>
<td><strong>Building</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Create Polygon</td>
<td><img src="image" alt="icon" /></td>
<td>Mesh&gt;</td>
</tr>
<tr>
<td>Interactive Split</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Combine</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Separate</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Bridge</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Extrude</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Detach Component</td>
<td><img src="image" alt="icon" /></td>
<td>Edit Mesh&gt;</td>
</tr>
<tr>
<td>Mirror Geometry</td>
<td><img src="image" alt="icon" /></td>
<td>Mesh&gt;</td>
</tr>
<tr>
<td><strong>Optimize</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sculpt - Relax</td>
<td><img src="image" alt="icon" /></td>
<td>Mesh&gt;</td>
</tr>
<tr>
<td>Display Border Edges</td>
<td><img src="image" alt="icon" /></td>
<td>Display&gt;Polygons&gt;</td>
</tr>
<tr>
<td>Cleanup...</td>
<td><img src="image" alt="icon" /></td>
<td>Mesh&gt;</td>
</tr>
</tbody>
</table>
**TIP: Shelves in Maya:** Store your favorite tools on a custom shelf in Maya. On any menu item in Maya, hold down CTRL+SHIFT while clicking on an item to place it on the shelf. You can select an icon and MMB drag to reposition it on the shelf. Be sure to use the "Save all Shelves" command to store your shelf. Shelves are portable and can be shared as well.

**Reference: Polygonal Modeling Flow Examples for Quads:**

*Based upon pixelsandpoly.com "Step-Down Guide"*
Excellent resources for Polygonal modeling reference:

3D Modeling Primer: Glen Southern
http://southerngfx.co.uk/tutorials/3d-primer-page-1

Polygon Tables for 3D Modeling (by Pedro Amaro)
http://i153.photobucket.com/albums/s202/animatics/Lightwave/Polygon-Table_v04.png

Poly Tables: Moving Poles (Pedro Amaro)
http://i153.photobucket.com/albums/s202/animatics/Lightwave/MovingPolesv01_web.png

What does that “Problems Detected” box in Mudbox mean? What do you mean it's a GOOD THING!?!?

Validate meshes on import
On by default, Mudbox automatically scans every FBX or OBJ mesh that you import to alert you to any potential problems before you spend time painting or sculpting. When off, imported files are not scanned. You can also select Mesh > Validate Meshes from the main menu bar at any time to scan all meshes in the scene.
When working in Mudbox, consider the following items for bringing in your base mesh:
(Source: Autodesk Mudbox 2013 documentation)

**UV Texture Coordinates**

Keep in mind how your desired workflow in Mudbox can impact the creation/layout of UVs in the original 3D modeling application. For example, if you plan to sculpt a model in Mudbox and extract either a Normal or Displacement map of the sculpted detail so it can be applied to a low resolution or arbitrary mesh for use in another application, ensure that the polygonal model has UVs, and that the UVs are non-overlapping. Also take note of the PTEX section on Page 13 of this document.

**Quads or N-gon faces**

It is recommended that you sculpt polygon models using four-sided polygons (quads). Three-sided and n-sided polygons are fully supported, but some visual artifacts can appear when three-sided regions of the model are subdivided to higher levels.

Regions of a model where the edge valency (the number of edges coming out of a vertex) is high may produce a pole effect that appears as a gathering of vertices which may prove difficult to smooth when sculpting. It is suggested that these areas be remodeled to reposition the pole to a different or more inconspicuous location.

**Size and shape of polygon faces**

The polygonal faces on the model should be of equal size and shape so they create smaller regions that are of equal size and shape and hold detail well when subdivided. When some faces are longer or wider, the sculpted detail can also be uneven or distorted by comparison.

**Edge loop/ring flow**

The initial distribution and layout of edge loops and edge rings on the imported model has an impact on sculpting. A good practice is to create a model specifically for sculpting rather than sculpt on the model that was specifically constructed for animation. While a model can be constructed in a way to anticipate its use for rigging or animation or particular visual features, this can limit options for sculpting features or making design changes downstream.

**Detail**

Ideally, a model that you want to subsequently sculpt in Mudbox should be modeled without specific detail (unless you are using Mudbox to enhance or complete a model that has already been well defined). That is, it is usually easier to define specific low and high resolution features within Mudbox (and iterate them) if they haven’t already been defined within the model you want
to import. For an example of low detail models, refer to the sculpt templates in the Create > Mesh menu.

**Location of model in X, Y, Z**

If you want to perform symmetrical sculpting operations on the model, ensure the model is positioned at the center of the 3D View in X, Y, Z (0, 0, 0) before you begin sculpting. While Mudbox provides features for working on asymmetrically posed models and models that have been offset from the X, Y, Z origin (within Mudbox), in general, best results are achieved when the model is located at the origin.

**Convert subdivision surfaces to polygons prior to export**

Before exporting your model from your 3D application, ensure it is converted to polygons. Some 3D applications allow the export of subdivision surfaces into the .obj file. SubD surfaces are not a valid surface type in Mudbox.

**Polygon topology**

Polygona l models can have different configurations or topology types. Understanding the characteristics of these topologies is helpful when you need to understand why a model fails to load into Mudbox.

Mudbox supports two-manifold polygon topologies. Two-manifold topology polygons have a configuration such that the polygon mesh can be split along its various edges and subsequently unfolded so that the mesh lays flat without overlapping pieces.

Mudbox does not support non-manifold polygon topologies. Non-manifold topology polygons have a configuration that cannot be unfolded into a continuous flat piece. Examples of non-manifold configurations include: t-intersections, where more than two faces share a common edge; bow ties, where two faces share a single vertex without sharing a face; non-contiguous normals, where adjacent faces have been combined so that the normals point in opposite directions. See “Reference: Polygonal Modeling” on Page 5 of this document.

Many 3D modeling applications can produce non-manifold polygon configurations whether it occurs deliberately by the user or accidentally by a modeling operation that is performed.

Mudbox supports polygon faces with a maximum of 16 edges.

Maya includes a feature called *Mesh > Cleanup*. 
Maya’s Mesh>Cleanup tool lets you filter through potential issues. Below is a screen grab of the basic settings that I would recommend you utilize for editing problem meshes. Note the “Select matching polygons” highlighted rather than “Cleanup matching..” . I feel this is important as it allows for another filter to be applied: your eyes. Let the Cleanup tool highlight the problems for you so that you can address how you want to fix them, or only what **NEEDS to be fixed**.

**Supported File formats for import into Mudbox:** `.fbx, .obj, .mud`
Sculpting in Mudbox:

Just like with clay, start low-res and blocky to build in initial forms. Don't jump too high in resolution at this stage. The idea is to begin to build up form and space. Higher resolution subdivisions aren't normally needed until finite details are required.

Layers – Mudbox is a layer-based sculpting and painting application. Take advantage of this and use layers as much as possible. Layers are a very effective way to store the overall history of your design build. There are also many other advantages to the use of layers in your workflow. As Mudbox can handle infinite sculpt and paint layers, it is very easy to extract specific areas of details for texture map creation (displacement, bump, normal, diffuse, specular, etc.). Another benefit to the use of layers in your Mudbox workflow is the ability to blend sculpting and painting detail between layers. Layers also provide an effective means of dampening or multiplying the overall effect of separate details.

Image Planes
Mudbox lets you import reference images for use as a guide while building up your overall concept. If using packages such as Max, Maya or Softimage, it is important to note that the one-click FBX workflow will transfer cameras and image planes into Mudbox perfectly. The image planes can be anything that will aid you in the exploration of your concept. In this case we are using some nice, line-drawing concept sketches out of Sketchbook Designer.

Organic Modeling Tools
The following tools (in the Sculpt Tray) are an excellent place to start for working in primary forms, such as muscle groups and areas of bulk mass:

- **Foamy** - Similar to the Sculpt tool but with a softer feel. Useful for designing initial forms, not intended for detail work.
- **Wax** - Builds up areas on a model, adding or removing material from the model surface, much like working with clay or wax.
- **Smooth** - Levels vertex positions in relation to each other by averaging the positions of vertices.
- **Grab** - Useful for making subtle adjustments to the form of the model.
**Hard-Surface Techniques**

Begin to define areas that need to be hardened/sharpened. The following tools represent the best choices for producing hardened-edged surfaces in Mudbox:

- **Flatten** - Levels affected vertices by moving them toward a common plane. Useful for designing and detailing.
- **Pinch** - Pulls vertices in towards the center of the tool cursor. Useful for more sharply defining an existing crease.
- **Scrape** - Useful for minimizing or removing protruding features. Quickly calculates a plane (based on the vertex positions wherever the cursor is first placed) then flattening any vertices above the plane.
- **Fill** - Fills in cavities on the model surface by calculating a plane (based on the average of the vertices within the tool cursor), then pulling vertices under the plane towards that plane.
- **Sculpt** - Builds up initial forms and moves vertices in a direction determined by the average of all normals within the boundary of the tool cursor. Use the Direction property to modify the default setting (for example, Camera, X, Y, Z and so on). This tool is most-effective for hard-edging when used with stamps (vector displacement produces the best results).

**TIP:** Mudbox supports **hard edges defined from Maya and Max**. Subdivision creases, and normals defined for hardened edges can be preserved in subdivision in Mudbox. For Maya, export your mesh to Mudbox as FBX with *Smooth Mesh Preview* enabled.

**Finite Details**

Use the default **Stamps** and **Stencil** set in Mudbox or your own library of textures to define finite details such as: wrinkles, scales, skin, pores, etc.

Let’s take a look at **Vector Displacement** in Mudbox and how it can be a very powerful tool for storing and repeating specific details on a surface.

Vector displacement mapping provides an effective and efficient means for the storage and transfer of complex, multidirectional geometric details. Unlike traditional displacement maps, intricate forms with appendages, undercuts, folds, and bulges, such as a human ear can be stored and reused throughout the sculpting and detailing process. Tools and brushes within
Mudbox can be customized with vector displacement to provide specific effects on a mesh. Furthermore, vector displacement libraries also allow intricate and complex details to be quickly accessed and reused in a sculpting workflow. The use of vector displacement mapping to help preserve, or maintain, a specific look, design, or style can aid in any sculpting-based pipeline. For more in-depth information on vector displacement, please refer to these references:

**Books:**


**Videos:**

http://www.youtube.com/watch?v=QuGDdhSqiLg&feature=related

http://www.youtube.com/watch?v=6GFoH1ET6JE&feature=relmfu

**Docs:**


**Tips/Tricks:**

- Always have your Sculpt Strength set to 100 in order to receive the full, accurate results from the vector displacement map
- Build-up can be adjusted to a higher value to provide quicker brushing of details onto a surface
- There are advanced settings that provide alternate directions to apply brush strokes. These can be found under the Advanced tab in the Sculpt tool properties.
Texture Painting:

Mudbox is an incredibly powerful high-resolution painting application. There are many options for painting models in Mudbox with or without UV coordinates. In this example, we are looking at painting textures on our concept model that has UVs. The UV window in Mudbox can be found in the second tab in the top left corner, above the viewport. If your object does not have UVs, you can easily click: Mesh>Create UVs. This will produce a basic UV layout that will get you up and running with texture painting. In the case of this creature workflow, I am using a UV-less workflow (Ptex). The paint can later be transferred to a properly UV laid-out model later on using the Transfer Paint Layers under Maps>Extract Texture Maps.

For concept creation, we can use real-world images to project details on to our model, or use hand-painted brush strokes to achieve the desired look. Once again, use layers to store variations of your design. Paint Layers provide an excellent way to visualize the following:

- Texture variations
- Material/Fabric swatch changes (ie. leather vs cloth materials)
- Colour and creature skin styles
- Logo or tattoo placements and variations

Tips:
- Build up texture libraries and bookmark them in the built-in Image Browser in Mudbox. You can view and assign textures to stencils and stamps from this browser.
- Mudbox works incredibly well with Photoshop. Right-click on any paint layer to access the Export to PSD option. Think of Photoshop as an extension to Mudbox when texture painting.

Painting with PTEX:

Traditional texture mapping methods are plagued with many technical drawbacks: texture seams and artifacts, the tedious task of UV layout, and, data tracking with the large numbers of texture maps in a pipeline. PTEX was developed by researchers at Disney to address these issues. Since its initial use on the film Bolt, PTEX is the primary texture mapping method for all productions at Walt Disney Animation Studios (yes, Wreck it Ralph being the most recent).

For more information on the research work at Disney on PTEX:

With PTEX painting, you apply paint to each base face of the mesh, creating high resolution detail without needing explicit UV coordinates. For an entirely UV-free pipeline, you can export your high-quality textures as PTEX files, or if your pipeline requires UVs, bake your textures to UV space (once UVs have been created) and export them as image files. Think of a PTEX-prepped mesh as you would subdivided geometry: **A uniform and balanced “layout” across the surface to allow for smooth texture painting.** Of course all of the painting tools, blend modes, colour adjustment tools and techniques are fully compatible with PTEX painting.

PTEX provides a UV-less workflow, no waiting for UV coordinates to come down the pipe, and is supported in Maya’s Viewport 2.0. A fallback, however, is that Ptex files cannot be edited in Photoshop much like a UV-coordinate based texture. The adjustment and editing tools in Mudbox, however, provide a very powerful way to edit and adjust the resulting texture.

With PTEX, we can paint without UVs and, if necessary, transfer all of the paint layers to a UV equipped model at a later time.
Better than Baking: Transfer Paint Layers

Under the Maps>Extract Texture Maps menu set, you will find the Transfer Paint Layers option. Mudbox allows you to bake textures between objects.....but WAIT, it’s much more than that. You are transferring all of the art history, every brush stroke, colour adjustment, layer, edit, etc. between models. This is very handy for pipelines with multiple iterations of objects where texture variations are important. Paint layers can even been transferred at a larger resolution than they were painted at. Furthermore, all of this can also be accomplished between completely dissimilar meshes. Paint with PTEX and transfer to a mesh with UVs later!
Presentation/Real-Time Rendering:

The three primary uses of Mudbox are: **Sculpting**, **Painting** and **Presentation**. We’re going to take a look at the Presentation toolset here. Using Mudbox as a tool for design visualization couldn’t be easier. Mudbox has a real-time rendering environment that allows for high-resolution objects to be textured, lit and visualized in a viewport context. Of course, sculpt and paint changes can take place while viewing a model in this context. Adding different lights, including image-based lights, to a scene can have a dramatic effect and is an excellent way to visualize a design or prepare images for viewing of design variations and iterations. Using a combination of material settings, lighting and viewport filters, it is also very easy to generate render passes such as: specularity, flat diffuse, alpha, ambient occlusion, cavity (detailed ambient occlusion), shadow passes, reflection and z-depth. Splitting everything into passes provides plenty of control over your final image. The **rendering of images and turntables in Mudbox can be found under the Render menu set**. For more information on Render Passes in Mudbox, take a look at my video here:

http://www.youtube.com/watch?v=DGuUpnc-X1U

**Viewport Filter tips and tricks:**

**Tonemapper:** The *Adaption* parameter provides accurate feedback to lighting changes when orbiting around in the viewport. In essence, *Adaption* is taking into consideration the changes from specularity, reflection, etc. cast from the object to the camera and updating the view accordingly. Tuning *Adaption Time* and *Epsilon* down to zero is an excellent way to “lock” the overall lighting for screen renders.

**Ambient Occlusion:** This filter can be quite GPU intensive in the viewport, although it does produce some very nice results for rendering. Turning the number of casts and directions up to a much higher number will produce smoother results. Enable “Only AO” to preview the results on your object against white.

**Cavity Map:** Cavity maps are an excellent way to emphasize finite details on a surface. Cavity maps are very useful for giving your image that final “pop” for details. For more information on how to work with Cavity Maps in Mudbox, check out my article and video in **3D World Magazine** here:

http://the-area.com/blogs/craig/tips_and_tricks_generating_cavity_maps_in_mudbox