Managing Construction Phase Revisions with Autodesk® Revit®
Daniel John Stine – LHB

AB4009 This class will focus on the challenges of managing construction-phase drawing revisions with Revit Architecture, Revit Structure, and Revit MEP. We will present an overview of the entire process. You will learn the ins and outs of the revision feature and about clouding and tagging by sheet or by project, including using the Revisions dialog box. A major aspect of revision drawings is managing views and creating new ones for both letter (8 ½ inches x 11 inches) and tabloid (11 inches by 17 inches) drawing sizes. We will cover how these post-bid views should be placed under special headings in the Project Browser. The class will explain how to know when to use a Dependent View instead of duplicating a view for smaller drawings sizes. We will cover procedures and present tips and tricks to help you manage the revisions for any size project while creating an up to date building information modeling (BIM) record set for archiving or facility management.

Learning Objectives
At the end of this class, you will be able to:
- Understand the basic Revision tools
- Creating views for revision drawings
- Project Browser organization for revision views
- Using a special title block to quickly print revisions
- Express tools Freeze Drawing can create static revision views

About the Speaker
Daniel John Stine, CSI, CDT is an author, instructor, BIM manager, and architect with nearly 20 years of experience. Working full-time at LHB, a 160-person multidiscipline firm in Minnesota, Daniel provides training and support for all versions of Autodesk® Revit®, AutoCAD® Civil 3D®, and AutoCAD. Dan is a member of the Autodesk Developer Network and an Autodesk Revit Architecture 2011 Certified Professional. He teaches AutoCAD and Revit classes at Lake Superior College. Leveraging his professional experience, Daniel has also written the following textbooks: Design Integration using Revit 2012 (Architecture, Structure and MEP), Commercial Design using Revit Architecture 2012, Residential Design using Revit Architecture 2012, Residential Design using AutoCAD 2012 and Commercial Design using AutoCAD 2012. Finally, Daniel (and the electrical department at LHB) was involved with the development of the “Electrical Productivity Pack for Revit MEP” offered by Cad Technology Center (CTC).
Agenda:
The following is an outline of topics to be covered:

- Completion of construction documents; archive model
- Basic overview of Revisions
- Revisions During Bidding; Addenda
- Revisions During Construction; PR’s, CO's, CCD’s, etc.
- Project Browser Organization
- Custom Revision Tag
- “Magic” Titleblock
- Static View Option
- Autodesk Design Review integration
- Miscellaneous notes and tips
- Definitions

Completion of Construction Documents:
Archive the project once it has gone out for bids. This should be done before making any revisions to the project.

- Open with Audit/Detached checked
- Purge Unused (twice in 2012)
- Look for “not on sheet” via Project Browser filter (should have been done earlier in project)
- Save to archive folder
Basic Overview of Revisions:

- Specific revisions are managed via the Revisions dialog
  - Tool location: View → Revisions
- Revision Clouds are added and assigned to a specific Revision
  - Tool location: Annotate → Revision Cloud
  - Each cloud can be a separate instance or multiple clouds can be created in a single sketch (per sheet).
- A tag is added to a cloud to identify it
  - Tool location: Annotate → Tag by Category (or QAT)
- The revision schedule, in the titleblock family, updates automatically
  - Edit sheet properties to show revision w/o cloud
- When a revision will no longer be changed, it is marked as issued
  - Issued revisions cannot have new clouds added to them
- Older revisions can be made invisible on the sheets; via Show options.

In the big picture of BIM, Revit revisions are superficial in that the actual model elements being changed do not know which revision they belong to.
Revisions during Bidding:

- Setup the Revision dialog for the anticipated change to the model
- Make changes to model; e.g. edit Break Room (plan and elevation)
- Duplicate elevation view (with Detailing or as Dependent)
  - With Detailing option
    - Can move view to another category in Project Browser
    - All view specific elements are now copied; i.e. text, dimensions, detail lines (harder to keep in sync)
    - Crop region can be adjusted if needed
  - As Dependent option
    - View stays “close” to the original view
    - Does not duplicate view specific items (less chance for errors later)
    - Scale cannot be changed from master view
  - Both scenarios have the following issues:
    - New view cannot have the same name as the original
      - Workaround: add a period at the end
    - A new elevation tag added in the plan views
      - To hide these (steps required for each view):
        - Select each one and right-click → Hide in view, - or -
        - Create a new elevation tag type and filter it out
- Duplicate plan view as dependent
  - View can be cropped
    - Grids follow crop region
    - Section heads can be adjusted manually (but do not affect master view)
    - Annotation Crop must be turned on
      - Some annotations extend outside of crop
        - These can be hidden via select/right-click/Hide element
        - Slight problem for inline posting of plan rack set
- Annotations are not duplicated
- Notice all callouts get reset (and have to be manually adjusted)

- Add Revision clouds and tags to each sheet
  - Revision clouds/tags can be added directly in most views (rather than placing them on the sheet).
  - Adjust revision cloud line weight and color (if desired)
    - Manage → Object Styles → Annotation Objects
      - Could also change a given view typing VV
    - Warning: Changing color can affect printing
    - See my article on AECbytes.com for related information
      - “Controlling the Graphical Representation of Elements in Revit”

- Create a Revision sheet and place duplicated / dependent view on it
  - Revit only allows a view to be placed on one sheet.
  - Workaround to this presented later

Archive project at end of bidding (per steps outlined previously)


Revisions during Construction:
During construction you will most likely want to clear out all the bidding phase revisions and have the numbering start over for construction phase revisions.

- Archive project (per steps above)
- Delete all revisions clouds and tags from project
  - Must un-check the “issued” option first
- Merge all revisions in Revision dialog
  - Must un-check the “issued” option first
  - FYI: Revisions cannot be deleted (only merged)
- Start documenting construction phase revisions (e.g. PR-01, ASI-01, CO-01)
- Consider getting rid of any Design Options used for Bid Alternates
  - This makes revisions easier during CA
  - Set selected option to Primary and Accept it (via Design Options dialog)
  - Delete any unneeded sheets/views related to alternates
  - Warning: this can get messy for large complex alternates
    - Dimensions and tags can be deleted
  - The deleted options will be available in the archived project

All Construction Administration (CA) phase revisions should be made to a single model (i.e. the main model). This way any implications CO-04 might have on PR-57 will be evident to all parties.

In an IPD scenario (or design build) the best approach is to utilize a single model. This can be accomplished utilizing technology such as Remote Desktop (RDP) or Autodesk’s Revit Server.

Example 1: Proposal Request
The biggest challenge related to Proposal Requests (PR) is should the main model be edited or not? This is due to fact that the PR might not ultimately be accepted due to contract implications (time/cost). If it is highly likely that the PR will be accepted (e.g. code or errors/omissions required change), then the main model should be edited.

If the change is not likely (e.g. client is curious what another 50'-0" of building is worth), then a temporary copy of the model could be made (via open detached, save-as). However, in the unlikely event the PR is accepted, then the main model needs to be updated (some copy/paste might help, but will not cover everything).

When in doubt, make changes to the main model and undo them if the change is not accepted. Of course, you can do whatever you want in this case.

- Make change to south elevation
  - Remove window from exterior wall
Managing Construction Phase Revisions with Autodesk® Revit®

- Add callout and adjust ref. bubble position
- Create duplicate w/ detailing or dependent
  - Notice callout ref bubble resets

**Example 2: Schedules**
- Make a change to the door schedule
  - Note that revision clouds cannot be added to the view
- Add a door which causes the clouded items to shift down in the schedule
  - Notice clouds do not move with highlighted area
  - Designer must manually move cloud when changes such as this occur (if they can remember!).
- Move the revision cloud
  - Revision must be unissued before the cloud can be moved.

![Autodesk Revit Architecture 2012](image)
“Project Browser Organization

Sorting sheets can be done by creating a Project Parameter such as Sheet Group. In the image to the right, all sheets listed under Addendum, in the Project Browser, have their Sheet Group parameter set to the word “Addendum”.

Here is how to create a project parameter associated with sheets:

1. Click Manage → Project Parameters.
2. Make the following edits:
   a. Name: Sheet Group
   b. Type of Parameter: Text
   c. Instance: Checked
   d. Categories: Sheets
3. Close the open dialog boxes

Now all sheets will have a parameter called “Sheet Group”.

The following steps show how to sort the sheets by the Sheet Group parameter:

1. Right-click on the word Sheets (All) in the Project Browser.
2. Select Type Properties from the pop up menu.
3. Change the Type drop-down to Drawn By; activates Duplicate.
4. Click the Duplicate button.
5. Enter Sheet Group for the name. (this is case sensitive)
6. Edit the Folders option (see image on next page)
   a. Group By: Sheet Group
   b. Sort By: Sheet Number
Managing Construction Phase Revisions with Autodesk® Revit®

Creating a Project Parameter

Sorting and Grouping the Project Browser
All sheets which do not have a value in the Sheet Group parameter will show up under the “???” section; this will be all of the sheets at first. Simply select one or more sheets and edit the Sheet Group parameter in the Properties Palette. When you click Apply the sheets will automatically move to the specific “folder”.

The same process is followed to sort views. It is also possible to use the same parameter to sort both sheets and views. When setting up the sorting/grouping for the views, be careful not to duplicate the “not on sheet” option, as it has views filtered out (i.e. hidden).

Custom Revision Tag

The value in the default revision tag is not editable. It is possible to create a custom revision tag in order to control the information displayed. This custom tag has to use one of the built in parameters (i.e. Issued to or Issued by) as custom revisions parameters cannot be created. Here is the workflow to create a custom revision tag:

1. Open the default revision tag in the family editor
2. Select the Label
3. Click Edit Label on the Ribbon (see image below)
   a. Remove “Revision” from the right
   b. Add Issued by to the right
   c. Change the Sample Value to “AD01” (or similar)
4. Save as with a new file name
5. Load the new revision tag in the project
6. Edit the Issued by column in the Revisions dialog
Once the revision tag has been edited and used, the revision schedule in the titleblock can be edited to list and sort by the “Issued by” parameter. The titleblock must be edited in the Family Editor.

FYI: you may want to leave the sorting by “Revision Sequence” so the revisions appear in chronological order.
“Magic” Titleblock
Some design firms are using a workflow which eliminates the need to create additional views and sheets above those required for the original construction documents. The “magic” titleblock basically has a masking element within it which hides everything outside the border; we will call this the “revision titleblock”.

The process looks like this:

- Make revisions to model (as previously described)
- Cloud and Tag revisions (as previously described)
- Place the revision titleblock on a sheet
  - Main titleblock is not touched
  - Revision titleblock hides everything outside the 8 ½”x11” or 11”x17” border (including the main titleblock)
  - Size and position of crop window can be adjusted within the revision titleblock.
- Delete or hide the revision titleblock
- The PDF is the final record drawing.

A great 8 ½” x 11” revision titleblock can be downloaded from AGUI at:


This was created by David Kingham and David Baldacchino!

*Need to add shared parameter (export from family to new file)

*Need to adjust line weights 13 and 14 in project file

Revision titleblock placed on full size
Static View Option
Some firms are using a workflow which employs an option similar to the Revision Titleblock, which does not require duplicate/dependent views, but keeps a printable sheet more readily accessible from within Revit. This option basically captures a snapshot of the revised view and places it on a new sheet. The nice thing about this method is it can be quickly printed from Revit at any time, and future revisions will not change the drawing (in relation to how it was issued). The main drawback is this can have a negative impact on the project file size for larger projects.

There are a couple of ways in which this workflow can be accomplished. The first is creating a raster image and the second is using a tool in the Revit Extensions add-in (Freeze Drawings) available through subscription.

Raster Image Method:
This option involves exporting a raster image file and then linking it back into a new Drafting View. This new view can then be placed on a new Sheet. The workflow looks like this:

1. Make revisions as previously described
2. Export the revised drawing to a raster image
   a. Application Menu → Export → Images and Animations → Images
   b. See notes below on various quality/scale issues
3. Import the image into a new Drafting View
4. Place the Drafting View on a sheet (i.e. a new revision sheet)

The only way to get the image to scale is by using the following settings (see image below):

- **Export Range**: Current window
- **Image size**: Zoom to 100%
- **Format**: JPEG (lossless) and 72 dpi
Managing Construction Phase Revisions with Autodesk® Revit®

Exporting a raster image

This works well for details or cropped views, but creates a larger than needed image of an entire floor plan when just a small area is needed. Also, the 72dpi resolution is on the low side. Another option is to select the “Visible portion of current window” option and increase the resolution. Either of these changes makes the image not to scale. However, the image can be scaled once placed in the Drafting View.

If the revision needs to be changed and reissued, a new image is created and the old one replaced in Revit.
**Freeze Drawings Method:**

This option is generally identical to the Raster Image option, except that a vectorized image is created. This format will have a smaller impact on the model size than a raster image.

The **Freeze Drawings** add-in is part of the *Revit Extensions* available through Autodesk Subscription. This routine basically creates a CAD file in a new *Drafting View*. This cad file can be dimensioned because the lines are selectable. It can also be exploded and edited if desired. However, it would probably be best to edit the original and re-freeze the drawing. A masking region may also be added to hide portions of the view (*TIP*: use the magic titleblock on an 8 ½" x 11" sheet).

The workflow looks like this:

1. Open the revised view
2. Add-ins → Extensions Manager
3. Double-click Freeze Drawings
4. Click OK (see image below)
5. Find and rename newly created *Drafting View* in PB
6. Place view on new sheet.
Design Review Integration
This last method is proposed as a workflow which utilizes more advanced and efficient revision clouding tools (this may be debatable); Autodesk Design Review. This process can also be used for redlines / markups, which is actually what this functionality was developed for. The process for each revision (i.e. AD-001, AD-002, etc.) looks something like this:

1. Make revisions to the model
   a. Do not add clouds/tags
2. Export revised sheets to a multi-sheet DWFx file
   a. Only the sheets for the given revision should be exported.
3. Add clouds and tags in Autodesk Design Review.
4. Save the edited DWFx file
5. In Revit, select Insert → DWF Markup
   a. Repeat for each sheet in the DWF file
6. Edit the Revisions on Sheet settings so the titeblock updates

DWF markups can be removed from Revit via the Manage → Manage Links tool. Lineweights and color of the clouds/tags can be controlled via VV → Imported Categories.

Revision cloud in Revit added via Design
Miscellaneous Notes and Tips:
The following are various comments, notes and tips you may find useful.

- Revision schedules
  o Revision Schedule in the family editor is unique from a schedule created in the project environment.
    ▪ It lists revisions on the current sheet
    ▪ For sheets with many revisions, a revision schedule could be created in an empty titleblock family and positioned anywhere on the sheet.
    ▪ Revision schedule must be selected in the PB to see the sorting/grouping edit buttons in the *Properties Palette*.
  o Revision schedules can grow down or up. The standard for many firms is bottom up.

- Ways to hide revision clouds
  o hide in view via right click --> Category; revision still appears in revision schedule on sheet
  o hide via the Revision dialog box; revision still appears in revision schedule on sheet
  o hide in view via right click --> Element; the revision does not appear in the revision schedule on the TB
    ▪ *Warning*: when using the “by sheet” revision method, the revision number changes (i.e. always a #1 revision visible)!
  o hide via model crop (with annotation crop checked); the revision does not appear in the revision schedule on the TB
    ▪ for this last option, the "revisions on sheet" can be unchecked even if a cloud was hidden via a crop
Definitions:
Just so we are on the same page, as some use un-official terms such as “sketch”, and others outside the USA use their standard terminology.

- **Addenda (AD):**
  Revision to CD’s during bidding

- **Architectural Supplemental Information (ASI):** Drawing prepared to change the construction contract, but does not impact time/cost of the project.

- **Construction Administration (CA):**
  Services performed by designer team during construction phase

- **Construction Change Directive (CCD):**
  Drawing prepared to change the construction contract prior to acceptance by all parties.

- **Construction Documents (CD):**
  Drawings used by contractor for bidding

- **Change Order (CO):**
  Drawing prepared to change the construction contract

- **Proposal Request (PR):**
  Drawing prepared to determine time/cost implications of a proposed change to the construction contract

- **Project Browser (PB):**
  Organizes all views, sheets, schedules and families in Revit.